Archiv der Kategorie: Vermischtes

Lösung für Facebook-Fehlermeldung „This Page isn’t eligible to have a username.“

Wer hin und wieder Facebook-Seiten erstellt, kennt vielleicht das Problem, dass man manchmal einfach keinen Benutzernamen für die Seite vergeben kann. Das Problem tritt wohl willkürlich auf. Ich selbst hatte zwei fast identische Seiten kurz hintereinander erstellt. Bei der einen klappte die Vergabe des Benutzernamens problemlos, bei der anderen wurde ich stets mit der Fehlermeldung „This Page isn’t eligible to have a username.“ abgespeist. Wenn man im Netz danach sucht, findet man viele verzweifelte Leute und auch Lösungsansätze, die aber nicht immer vollständig sind. Mit der folgenden Methode hat es bei mir auf Anhieb geklappt:

  1. Bitte einen Freund um Hilfe, oder lege dir kurzerhand einen neuen Account auf Facebook an.
  2. Wichtig ist, dass der Hilfsaccount (Account des Freundes oder neuer Account) eine Telefonnummer angegeben hat, die per SMS bestätigt ist! Ich konnte ohne Probleme dieselbe Telefonnummer verwenden, die ich auch für meinen echten Account benutze. Man bekommt dann lediglich per E-Mail eine Warnung, dass ein anderer Account dieselbe Nummer verwendet hat, und wenn man die Zwei-Faktor-Authentifizierung mittels SMS aktiviert hat, wird sie sicherheitshalber deaktiviert, lässt sich danach aber wieder aktivieren.
  3. Trage in den Einstellungen der Seite, für die du den Benutzernamen vergeben möchtest, unter „Rollen für die Seiten“ den Hilfsaccount als zusätzlichen Administrator der Seite ein. Der Hilfsaccount erhält daraufhin eine Einladung, die er akzeptieren muss.
  4. Der Hilfsaccount sollte nun in der Lage sein, der Seite einen Benutzernamen zu geben. Bei meinem ersten Versuch bekam ich nun die leicht anderslautende Fehlermeldung „You’re not eligible to create a username.“, da ich den Account noch nicht mittels SMS bestätigt hatte. Nachdem ich das nachgeholt hatte, lief alles reibungslos.
  5. Zum Abschluss sollte der Hilfsaccount seine Administratorrolle wieder aufgeben.

Ich hoffe, dass dies dem einen oder anderen hilft!

Upgrade auf Windows 10 und nicht mehr funktionierendes Wake on LAN

Obwohl ich mit dem Upgrade von Windows 8.1 auf Windows 10 eigentlich ein wenig warten wollte, bis die gröbsten Fehler behoben wurden, habe ich dem verlockenden Angebot doch nur ein paar Tage standgehalten.

Das Upgrade selbst lief zu meiner Überraschung fast problemlos. Ich musste lediglich einmal den Rechner komplett ausschalten, damit ich wieder Internetzugang bekam — ein Neustart reichte nicht aus …

Heute wollte ich dann zum ersten Mal nach dem Upgrade aus der Ferne meinen Rechner starten, um auf eine lokale Datei zuzugreifen. Zu diesem Zweck habe ich Wake on LAN eingerichtet, was äußerst praktisch ist. Es erlaubt mir, den Rechner über das Web-Interface meiner FRITZ!Box einzuschalten, um mich dann mit Remote Desktop darauf anzumelden.

Genau das funktionierte nun nach dem Upgrade plötzlich nicht mehr. Wenn man im Internet nach dem Problem sucht, findet man normalerweise drei Hinweise:

  1. Man soll das Windows-Feature Fast Startup (Schnellstart) deaktivieren, denn ansonsten wird der Rechner beim Herunterfahren nicht komplett ausgeschaltet, sondern nur in einen sehr sparsamen Energiesparmodus versetzt, aus dem er sich eventuell mittels Wake on LAN nicht aufwecken lässt.
  2. Man soll im Gerätemanager bei den Geräteeigenschaften des Netzwerkadapters sicherstellen, dass dieser den Rechner aufwecken kann.
  3. Man soll im BIOS überprüfen, ob Wake on LAN aktiviert ist.

Alles war bei mir der Fall — die Einstellungen wurden vom Upgrade-Prozess wohl übernommen, und die BIOS-Einstellungen werden (hoffentlich) davon nicht beeinflusst.

Nach einigem verzweifelten Herumprobieren sah ich dann im Gerätemanager, dass der Treiber für den Intel-Netzwerkadapter ein Standardtreiber von Microsoft war. Zuvor hatte ich den Intel-Treiber installiert, aber dieser wurde wohl beim Upgrade auf Windows 10 ersetzt.

Nachdem ich nun wieder den Intel-Treiber für Windows 10 installiert und den Rechner einmal neugestartet habe, funktioniert Wake on LAN wieder einwandfrei! Dass es sich um ein Treiberproblem handelte, erscheint mir seltsam, denn wenn der Computer ausgeschaltet ist, spielen Treiber keine Rolle. Aber möglicherweise versetzt der Intel-Treiber den Netzwerkadapter in einen speziellen Modus, in dem er auf Wake on LAN-Pakete wartet, bevor der Rechner heruntergefahren wird.

Expedition ins schwarze Loch

… so hieß eine Dokumentation, die ich gerade auf N24 gesehen habe. Es handelte sich dabei um eine Folge von Sci Fi Science: Physics of the Impossible. Was einem da geboten wurde, war absolut haarsträubender Unfug, der aber so präsentiert wurde, als ob es sich dabei um wissenschaftliche Fakten handeln würde.

Laut Michio Kaku, dem Moderator der Sendung, sollte es möglich sein mit einem Raumschiff in ein schwarzes Loch zu fliegen. Es gibt da nur ein Problem, das er Spaghettisierung nennt: Das Raumschiff wird zu einem Punkt zerdrückt bzw. unendlich in die Länge gezogen. Aber das ist ja nicht so schlimm, dann nähern wir uns dem schwarzen Loch einfach von oben(!), wo sein Gravitationsring nicht so stark ist. Dort ist es ganz ruhig, wie im Auge eines Wirbelsturms, so dass wir bis zur Öffnung des „Wurmlochs“ vordringen können. Aber so ein Wurmloch ist sehr instabil, wir müssen es offen halten. Dazu brauchen wir die seltenste Substanz des Universums: negative Materie. Die gibt es in Form von negativen Asteroiden am Rand des Universums. Wir schicken also ein paar Drohnen zum Rand des Universums, um sie einzusammeln. Habe ich schon erwähnt, dass negative Materie Antigravitation erzeugt? Damit können wir das Wurmloch stabil halten und hinein fliegen. Natürlich ergibt sich all das aus den Gleichungen von Albert Einstein! Die Leute, die der Moderator fragte (es handelte sich sinnvollerweise um betrunkene Besucher einer Diskothek), hielten die Vorgehensweise jedenfalls für eine gute Idee und würden sich sofort mit Michio Kaku ins Raumschiff setzen.

N24 ist mit dieser Sendung in ein schwarzes Loch der Fernsehqualität eingetaucht. Ich habe mir die ganze Zeit überlegt, was Harald Lesch wohl dazu sagen würde. Wahrscheinlich würde er tot umfallen.

NVIDIA-Treiber müllen Systempartition voll

Wer unter Windows regelmäßig seine NVIDIA-Grafikkartentreiber aktualisiert oder gar ständig die neuesten Betaversionen installiert, dem könnte bereits aufgefallen sein, dass nach jeder solchen Aktion etwas weniger freier Speicher auf der Systempartition übrig bleibt. Gerade bei einer SSD ist das ärgerlich, da diese für gewöhnlich nicht so groß ausfallen wie normale Festplatten.

Der Grund für den Platzschwund liegt darin, dass der Installer immer noch eine Kopie der gesamten Treiberkomponenten aufbewahrt, und zwar für jede Version, die man jemals installiert hat!

Um diesem hirnrissigen Spuk ein Ende zu bereiten, kann man ganz einfach alle Unterverzeichnisse aus folgendem Verzeichnis löschen:

C:\Program Files\NVIDIA Corporation\Installer2

Natürlich sollte man auch nicht vergessen, den temporären Ordner zu löschen, in den der Installer extrahiert wird. Standardmäßig ist das C:\NVIDIA. Auch hier fällt gerne nochmal ein halbes Gigabyte an Müll an.

Nachtrag (4. April 2016): NVIDIA empfiehlt, vor der Installation einer neuen Treiberversion zunächst den vorhandenen Treiber zu deinstallieren. Alternativ kann man während der Installation die Option „Perform Clean Install“ auswählen, die das automatisch erledigt. So hält sich der Ballast in Zukunft hoffentlich in Grenzen.