Upgrade auf Windows 10 und nicht mehr funktionierendes Wake on LAN

Obwohl ich mit dem Upgrade von Windows 8.1 auf Windows 10 eigentlich ein wenig warten wollte, bis die gröbsten Fehler behoben wurden, habe ich dem verlockenden Angebot doch nur ein paar Tage standgehalten.

Das Upgrade selbst lief zu meiner Überraschung fast problemlos. Ich musste lediglich einmal den Rechner komplett ausschalten, damit ich wieder Internetzugang bekam — ein Neustart reichte nicht aus …

Heute wollte ich dann zum ersten Mal nach dem Upgrade aus der Ferne meinen Rechner starten, um auf eine lokale Datei zuzugreifen. Zu diesem Zweck habe ich Wake on LAN eingerichtet, was äußerst praktisch ist. Es erlaubt mir, den Rechner über das Web-Interface meiner FRITZ!Box einzuschalten, um mich dann mit Remote Desktop darauf anzumelden.

Genau das funktionierte nun nach dem Upgrade plötzlich nicht mehr. Wenn man im Internet nach dem Problem sucht, findet man normalerweise drei Hinweise:

  1. Man soll das Windows-Feature Fast Startup (Schnellstart) deaktivieren, denn ansonsten wird der Rechner beim Herunterfahren nicht komplett ausgeschaltet, sondern nur in einen sehr sparsamen Energiesparmodus versetzt, aus dem er sich eventuell mittels Wake on LAN nicht aufwecken lässt.
  2. Man soll im Gerätemanager bei den Geräteeigenschaften des Netzwerkadapters sicherstellen, dass dieser den Rechner aufwecken kann.
  3. Man soll im BIOS überprüfen, ob Wake on LAN aktiviert ist.

Alles war bei mir der Fall — die Einstellungen wurden vom Upgrade-Prozess wohl übernommen, und die BIOS-Einstellungen werden (hoffentlich) davon nicht beeinflusst.

Nach einigem verzweifelten Herumprobieren sah ich dann im Gerätemanager, dass der Treiber für den Intel-Netzwerkadapter ein Standardtreiber von Microsoft war. Zuvor hatte ich den Intel-Treiber installiert, aber dieser wurde wohl beim Upgrade auf Windows 10 ersetzt.

Nachdem ich nun wieder den Intel-Treiber für Windows 10 installiert und den Rechner einmal neugestartet habe, funktioniert Wake on LAN wieder einwandfrei! Dass es sich um ein Treiberproblem handelte, erscheint mir seltsam, denn wenn der Computer ausgeschaltet ist, spielen Treiber keine Rolle. Aber möglicherweise versetzt der Intel-Treiber den Netzwerkadapter in einen speziellen Modus, in dem er auf Wake on LAN-Pakete wartet, bevor der Rechner heruntergefahren wird.

13 Gedanken zu „Upgrade auf Windows 10 und nicht mehr funktionierendes Wake on LAN

  1. Tobias

    Vielen Dank für den hilfreichen Tipp. Das Problem scheint sich nicht auf Intel-Netzwerkadapter zu beschränken – bei mir das gleiche Problem mit einem Realtek-Netzwerkadapter auf einem Gigabyte-Board. Erst die Installation des neuesten Treibers direkt von der Realtek-Seite ermöglichte mir ein Starten des PC per WakeonLAN.

    Antworten
  2. K. Mauser

    Hallo & vielen Dank, auch mir hat dieser Tipp den gewünschten Erfolg gebracht.
    Ich habe ebenfalls ein Gigabyte-Board mit einem Intel NIC onBoard. Wichtig ist noch zuu erwähnen, dass neben dem aktuellen Treiber von Intel, in der Adaptereigenschaften unter „Energieoptionen“, die Option „Computer kann das Gerät ausschalten, um Energie zu sparen“ NICHT aktiviert sein darf.

    Antworten
  3. Basti

    Ich habe ein Asus P8Z77-I Deluxe Mainboard und stand nach der Installation von Windows 10 ebenfalls vor dem Problem, dass das Wake-On-Lan per Teamviewer nicht mehr funktionierte. Wie richtig vermutet war auch in diesem Fall ein Microsoft-Treiber installiert. Nach dem Download und der Installation des Intel-Treibers von der Asus Webseite läuft nun alles wieder. Vielen Dank für den Tipp!

    Antworten
  4. plerzelwupp

    Wollte mich auch noch recht herzlich bedanken. Hatte das Problem ebenfalls, gleiche Geschichte, Bios, hibernate, Netzwerkkarte, usw… Alles stimmte. War schon am Verzweifeln. Letztendlich war es auch bei mir der Treiber.
    Viele Grüße
    Oliver

    Antworten
  5. Thomas F.

    Danke für den Tipp, aber leider scheint es für meine INTEL-Karte keine Windows10-Treiber zu geben, was ich ziemlich mies finde. Die Karte ist sicher noch millionenfach in Gebrauch. Also heißt es wieder einmal, neue Hardware kaufen, obwohl die alte nicht defekt ist.

    Antworten
  6. Andreas

    Hi,
    auch bei mir hat das Update auf den Netzwerktreiber des Netzwerkkartenherstellers geholfen.
    Leider habe ich das sporadische Problem (ungefähr jedes zweite mal), dass ich meinen Notebook über das Internet starten kann (ich verwende hierzu die AVM myfritz „Computer starten“-Funktionalität“), mich aber nicht über Teamviewer am Rechner anmelden kann. Sobald ich dann abends direkt am Notebook sitze sehe ich, dass der Notebook hochgefahren ist, sich aber nicht in das Internet verbindet – ich vermute die Bitdefender-Virenschutzsoftware muss ein Update machen. Hierzu ist nach Anmeldung jedes mal ein Neustart des Rechners erforderlich und es funzt wieder. Hat Jemand eine Idee, wie ich Bitdefender oder sonstwas konfiguriere, so dass auch bei erforderlichem Update erstmal eine voll funktionsfähige Verbindung zum Internet hergestellt wird?
    D+G
    Andreas

    Antworten
  7. Knebel

    Dasselbe Lied: WOL geht nicht mehr nach W10-Update.
    onboard PCI-e realtek-Netzwerkkarte. Treiber von der realtek-Website installiert, WOL geht wieder.
    Danke für den Hinweis!

    Antworten

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.